Castling problem in chess 960 Chess forum

9 replies. Last post: 2022-11-12

Reply to this topic Return to forum

Castling problem in chess 960
  • richyfourtytwo ★ at 2022-11-11

    In this game https://www.littlegolem.net/jsp/game/game.jsp?gid=2341155 neither player could castle, which we both don't understand (And that was BEFORE the king made a move.) Are we missing something in the rules or is it a bug?

  • Ray Garrison ★ at 2022-11-11

    looks like a bug…white could not castle either queenside or kingside? I recommend you report this to Richard

  • richyfourtytwo ★ at 2022-11-11

    To neither side. And seemingly my opponent had the same problem. (As per the chat.)

  • Richard Malaschitz ★ at 2022-11-11

    It should work to click on the king and then on the rook. In the mobile app (ios, https://www.littlegolem.net/app/ ) drag-and-drop works as well.

  • William Fraser at 2022-11-11

    I notice that in that clip, the king and rook started on their usual places of e1 and h1. Does it also work for other starting positions?

  • William Fraser at 2022-11-11

    Oh, never mind. I just realized that the king and rooks are in their usual places in the original poster's game, too.

  • richyfourtytwo ★ at 2022-11-12

    Ah, OK, so this has cahnged recently? Will try as soon as it's my move again.

  • Chris Smith at 2022-11-12

    I tried clicking on the king and rook in one of my other games and it worked. It's too bad there is no documentation (that I could find) that explains this interface difference from normal chess.

Return to forum

Reply to this topic